xterm & alt [2]

Remember my post on alt and xterm ?

Well, I have the solution now =)

Vous vous souvenez de mon billet sur alt et xterm ?

Et bien j’ai la solution ! =)

If you search for altsendsescape on the web, you will find a lot of solutions, saying that you have to edit your .Xdefault or .Xresources with something like:
XTerm*altSendsEscape: true
or *VT100*altSendsEscape: 1

I’m sure they are all good, but none were working with me: altSendsEscape wasn’t checked in the menu… So I went for XTerm*metaSendsEscape: true and this, it was checked. But I had to do a little trick to be able to type alt+. correctly. Also add in .Xdefault:
XTerm*eightBitInput: false

I still don’t know why, but it works now =)

Si vous cherchez altsendsescape sur le net, il y a plein de solutions, disant qu’il faut éditer son .Xdefault ou son .Xresources avec quelque chose gu genre :
XTerm*altSendsEscape: true
ou *VT100*altSendsEscape: 1

Je suis sûr que tous marchent bien, mais aucun ne marchait pour moi : altSendsEscape n’était pas coché dans le menu menu… Du coup je suis allé pour XTerm*metaSendsEscape: true et ça, c’était bien coché. Mais j’ai dû ajouter une petite ligne en plus dans .Xdefault pour pouvoir faire alt+. :
XTerm*eightBitInput: false

Je ne sais toujours pas pourquoi, mais ça marche =)

~ by loquehumaine on 2008, July 18 - Friday.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: